Skip to contentSkip to conversation

eglibc-2.18: Remove unused patches

PATCH New Khem Raj 1 participant 2 messages Jul 17, 2013

lore
Share & tools
lore

Khem Raj

author
#0 lore raw

PATCH 1/2 eglibc-2.18: Remove unused patches

These patches are already part of 2.18 eglibc
they were copied from 2.17 but never used.

---
 .../eglibc-2.18/eglibc-2.17-PR15003-r22243.patch   |  207 -
 .../eglibc/eglibc-2.18/eglibc-2.17-r22178.patch    | 9472 --------------------
 2 files changed, 9679 deletions(-)
 delete mode 100644 meta/recipes-core/eglibc/eglibc-2.18/eglibc-2.17-PR15003-r22243.patch
 delete mode 100644 meta/recipes-core/eglibc/eglibc-2.18/eglibc-2.17-r22178.patch
meta/recipes-core/eglibc/eglibc-2.18/eglibc-2.17-PR15003-r22243.patch deleted +0 -207
deleted file mode 100644
index a69302b..0000000
@@ -1,207 +0,0 @@
-Index: libc/NEWS
-===================================================================
---- libc/NEWS	(revision 22242)
-+++ libc/NEWS	(revision 22243)
-@@ -23,7 +23,7 @@
-   14767, 14783, 14784, 14785, 14793, 14796, 14797, 14801, 14803, 14805,
-   14807, 14811, 14815, 14821, 14822, 14824, 14828, 14831, 14833, 14835,
-   14838, 14856, 14863, 14865, 14866, 14868, 14869, 14871, 14872, 14879,
--  14889, 14893, 14898, 14914.
-+  14889, 14893, 14898, 14914, 15003.
- 
- * Optimization of memcpy for MIPS.
- 
-Index: libc/ChangeLog
-===================================================================
---- libc/ChangeLog	(revision 22242)
-+++ libc/ChangeLog	(revision 22243)
-@@ -1,3 +1,29 @@
-+2013-01-11  Andreas Jaeger  <[email protected]>
-+
-+	[BZ #15003]
-+	* sysdeps/unix/sysv/linux/bits/socket.h (MSG_FASTOPEN): New
-+	value. Sync with Linux 3.7.
-+
-+2013-01-09  David S. Miller  <[email protected]>
-+
-+	[BZ# 15003]
-+	* sysdeps/gnu/netinet/tcp.h (TCP_COOKIE_TRANSACTIONS,
-+	TCP_THIN_LINEAR_TIMEOUTS, TCP_THIN_DUPACK, TCP_USER_TIMEOUT,
-+	TCP_REPAIR, TCP_REPAIR_QUEUE, TCP_QUEUE_SEQ, TCP_REPAIR_OPTIONS,
-+	TCP_FASTOPEN): Define.
-+	(tcp_repair_opt): New structure.
-+	(TCP_NO_QUEUE, TCP_RECV_QUEUE, TCP_SEND_QUEUE, TCP_QUEUES_NR): New
-+	enum values.
-+	(TCP_COOKIE_MIN, TCP_COOKIE_MAX, TCP_COOKIE_PAIR_SIZE,
-+	TCP_COOKIE_IN_ALWAYS, TCP_COOKIE_OUT_NEVER, TCP_S_DATA_IN,
-+	TCP_S_DATA_OUT, TCP_MSS_DEFAULT, TCP_MSS_DESIRED): Define.
-+	(tcp_cookie_transactions): New structure.
-+
-+2013-01-09  Andreas Jaeger  <[email protected]>
-+
-+	* sysdeps/gnu/netinet/tcp.h (TCPI_OPT_SYN_DATA)
-+	(TCPI_OPT_ECN_SEEN): Define.  Sync with Linux 3.7.
-+
- 2013-01-01  David S. Miller  <[email protected]>
- 
- 	* po/fr.po: Update from translation team.
-Index: libc/sysdeps/unix/sysv/linux/bits/socket.h
-===================================================================
---- libc/sysdeps/unix/sysv/linux/bits/socket.h	(revision 22242)
-+++ libc/sysdeps/unix/sysv/linux/bits/socket.h	(revision 22243)
-@@ -1,6 +1,5 @@
- /* System-specific socket constants and types.  Linux version.
--   Copyright (C) 1991, 1992, 1994-2001, 2004, 2006-2010, 2011, 2012
--   Free Software Foundation, Inc.
-+   Copyright (C) 1991-2013 Free Software Foundation, Inc.
-    This file is part of the GNU C Library.
- 
-    The GNU C Library is free software; you can redistribute it and/or
-@@ -208,6 +207,8 @@
- #define	MSG_MORE	MSG_MORE
-     MSG_WAITFORONE	= 0x10000, /* Wait for at least one packet to return.*/
- #define MSG_WAITFORONE	MSG_WAITFORONE
-+    MSG_FASTOPEN	= 0x20000000, /* Send data in TCP SYN.  */
-+#define MSG_FASTOPEN	MSG_FASTOPEN
- 
-     MSG_CMSG_CLOEXEC	= 0x40000000	/* Set close_on_exit for file
- 					   descriptor received through
-Index: libc/sysdeps/gnu/netinet/tcp.h
-===================================================================
---- libc/sysdeps/gnu/netinet/tcp.h	(revision 22242)
-+++ libc/sysdeps/gnu/netinet/tcp.h	(revision 22243)
-@@ -37,20 +37,29 @@
- /*
-  * User-settable options (used with setsockopt).
-  */
--#define	TCP_NODELAY	 1	/* Don't delay send to coalesce packets  */
--#define	TCP_MAXSEG	 2	/* Set maximum segment size  */
--#define TCP_CORK	 3	/* Control sending of partial frames  */
--#define TCP_KEEPIDLE	 4	/* Start keeplives after this period */
--#define TCP_KEEPINTVL	 5	/* Interval between keepalives */
--#define TCP_KEEPCNT	 6	/* Number of keepalives before death */
--#define TCP_SYNCNT	 7	/* Number of SYN retransmits */
--#define TCP_LINGER2	 8	/* Life time of orphaned FIN-WAIT-2 state */
--#define TCP_DEFER_ACCEPT 9	/* Wake up listener only when data arrive */
--#define TCP_WINDOW_CLAMP 10	/* Bound advertised window */
--#define TCP_INFO	 11	/* Information about this connection. */
--#define	TCP_QUICKACK	 12	/* Bock/reenable quick ACKs.  */
--#define TCP_CONGESTION	 13	/* Congestion control algorithm.  */
--#define TCP_MD5SIG	 14	/* TCP MD5 Signature (RFC2385) */
-+#define	TCP_NODELAY		 1  /* Don't delay send to coalesce packets  */
-+#define	TCP_MAXSEG		 2  /* Set maximum segment size  */
-+#define TCP_CORK		 3  /* Control sending of partial frames  */
-+#define TCP_KEEPIDLE		 4  /* Start keeplives after this period */
-+#define TCP_KEEPINTVL		 5  /* Interval between keepalives */
-+#define TCP_KEEPCNT		 6  /* Number of keepalives before death */
-+#define TCP_SYNCNT		 7  /* Number of SYN retransmits */
-+#define TCP_LINGER2		 8  /* Life time of orphaned FIN-WAIT-2 state */
-+#define TCP_DEFER_ACCEPT	 9  /* Wake up listener only when data arrive */
-+#define TCP_WINDOW_CLAMP	 10 /* Bound advertised window */
-+#define TCP_INFO		 11 /* Information about this connection. */
-+#define	TCP_QUICKACK		 12 /* Bock/reenable quick ACKs.  */
-+#define TCP_CONGESTION		 13 /* Congestion control algorithm.  */
-+#define TCP_MD5SIG		 14 /* TCP MD5 Signature (RFC2385) */
-+#define TCP_COOKIE_TRANSACTIONS	 15 /* TCP Cookie Transactions */
-+#define TCP_THIN_LINEAR_TIMEOUTS 16 /* Use linear timeouts for thin streams*/
-+#define TCP_THIN_DUPACK		 17 /* Fast retrans. after 1 dupack */
-+#define TCP_USER_TIMEOUT	 18 /* How long for loss retry before timeout */
-+#define TCP_REPAIR		 19 /* TCP sock is under repair right now */
-+#define TCP_REPAIR_QUEUE	 20 /* Set TCP queue to repair */
-+#define TCP_QUEUE_SEQ		 21 /* Set sequence number of repaired queue. */
-+#define TCP_REPAIR_OPTIONS	 22 /* Repair TCP connection options */
-+#define TCP_FASTOPEN		 23 /* Enable FastOpen on listeners */
- 
- #ifdef __USE_MISC
- # include <sys/types.h>
-@@ -173,7 +182,9 @@
- # define TCPI_OPT_TIMESTAMPS	1
- # define TCPI_OPT_SACK		2
- # define TCPI_OPT_WSCALE	4
--# define TCPI_OPT_ECN		8
-+# define TCPI_OPT_ECN		8  /* ECN was negociated at TCP session init */
-+# define TCPI_OPT_ECN_SEEN	16 /* we received at least one packet with ECT */
-+# define TCPI_OPT_SYN_DATA	32 /* SYN-ACK acked data in SYN sent or rcvd */
- 
- /* Values for tcpi_state.  */
- enum tcp_ca_state
-@@ -241,6 +252,49 @@
-   u_int8_t	tcpm_key[TCP_MD5SIG_MAXKEYLEN];	/* Key (binary).  */
- };
- 
-+/* For socket repair options.  */
-+struct tcp_repair_opt
-+{
-+  u_int32_t	opt_code;
-+  u_int32_t	opt_val;
-+};
-+
-+/* Queue to repair, for TCP_REPAIR_QUEUE.  */
-+enum
-+{
-+  TCP_NO_QUEUE,
-+  TCP_RECV_QUEUE,
-+  TCP_SEND_QUEUE,
-+  TCP_QUEUES_NR,
-+};
-+
-+/* For cookie transactions socket options.  */
-+#define TCP_COOKIE_MIN		8		/*  64-bits */
-+#define TCP_COOKIE_MAX		16		/* 128-bits */
-+#define TCP_COOKIE_PAIR_SIZE	(2*TCP_COOKIE_MAX)
-+
-+/* Flags for both getsockopt and setsockopt */
-+#define TCP_COOKIE_IN_ALWAYS	(1 << 0)	/* Discard SYN without cookie */
-+#define TCP_COOKIE_OUT_NEVER	(1 << 1)	/* Prohibit outgoing cookies,
-+						 * supercedes everything. */
-+
-+/* Flags for getsockopt */
-+#define TCP_S_DATA_IN		(1 << 2)	/* Was data received? */
-+#define TCP_S_DATA_OUT		(1 << 3)	/* Was data sent? */
-+
-+#define TCP_MSS_DEFAULT		 536U	/* IPv4 (RFC1122, RFC2581) */
-+#define TCP_MSS_DESIRED		1220U	/* IPv6 (tunneled), EDNS0 (RFC3226) */
-+
-+struct tcp_cookie_transactions
-+{
-+  u_int16_t	tcpct_flags;
-+  u_int8_t	__tcpct_pad1;
-+  u_int8_t	tcpct_cookie_desired;
-+  u_int16_t	tcpct_s_data_desired;
-+  u_int16_t	tcpct_used;
-+  u_int8_t	tcpct_value[TCP_MSS_DEFAULT];
-+};
-+
- #endif /* Misc.  */
- 
- #endif /* netinet/tcp.h */
-
-Property changes on: libc/ports/sysdeps/unix/sysv/linux/powerpc/powerpc32/e500/single/nptl/c++-types.data
-___________________________________________________________________
-Modified: svn:mergeinfo
-   Merged /fsf/glibc-2_17-branch/libc/ports/sysdeps/unix/sysv/linux/powerpc/powerpc32/e500/single/nptl/c++-types.data:r22178-22242
-
-
-Property changes on: libc/ports/sysdeps/unix/sysv/linux/powerpc/powerpc32/e500/single/nptl/localplt.data
-___________________________________________________________________
-Modified: svn:mergeinfo
-   Merged /fsf/glibc-2_17-branch/libc/ports/sysdeps/unix/sysv/linux/powerpc/powerpc32/e500/single/nptl/localplt.data:r22178-22242
-
-
-Property changes on: libc/ports/sysdeps/unix/sysv/linux/powerpc/powerpc32/e500/nptl/c++-types.data
-___________________________________________________________________
-Modified: svn:mergeinfo
-   Merged /fsf/glibc-2_17-branch/libc/ports/sysdeps/unix/sysv/linux/powerpc/powerpc32/e500/nptl/c++-types.data:r22178-22242
-
-
-Property changes on: libc/ports/sysdeps/unix/sysv/linux/powerpc/powerpc32/e500/nptl/localplt.data
-___________________________________________________________________
-Modified: svn:mergeinfo
-   Merged /fsf/glibc-2_17-branch/libc/ports/sysdeps/unix/sysv/linux/powerpc/powerpc32/e500/nptl/localplt.data:r22178-22242
-
-
-Property changes on: .
-___________________________________________________________________
-Modified: svn:mergeinfo
-   Merged /fsf/glibc-2_17-branch:r22178-22242
-
meta/recipes-core/eglibc/eglibc-2.18/eglibc-2.17-r22178.patch deleted +0 -9472

2,793 lines not on this page · raw message

The rest of this diff is not shown. View the raw message.

Signature · 1 line
1.7.9.5

Part of the diff is not shown here. View the raw message.

author
#1 lore raw

PATCH 2/2 eglibc-2.18: Update to latest snapshot

Works on all supposted qemu machines

---
 .../eglibc/cross-localedef-native_2.18.bb          |    6 +++---
 meta/recipes-core/eglibc/eglibc_2.18.bb            |    6 +++---
 2 files changed, 6 insertions(+), 6 deletions(-)
meta/recipes-core/eglibc/cross-localedef-native_2.18.bb +3 -3
index 790f259..072b807 100644
@@ -16,11 +16,11 @@ inherit autotools
 # pick up an eglibc patch
 FILESPATH = "${FILE_DIRNAME}/eglibc-${PV}"
 
-SRC_URI = "http://sakrah.dontexist.org/files/eglibc-${PV}-svnr23424.tar.bz2 \
+SRC_URI = "http://sakrah.dontexist.org/files/eglibc-${PV}-svnr23532.tar.bz2 \
 	   file://fix_for_centos_5.8.patch;patchdir=.. \
 	  "
-SRC_URI[md5sum] = "e7bb555f34e782d428de3482d203df8d"
-SRC_URI[sha256sum] = "3824e699a91a34aebbe80bae9993b569616fad2056e4f6430cd455d604fb1d9c"
+SRC_URI[md5sum] = "8c83078851c44089a019c626d51c51bb"
+SRC_URI[sha256sum] = "ecd3167d7d417c05b10ea7ab8e3acbc05f4bc2b389b6fae9c186bc0fd34c3ff1"
 
 S = "${WORKDIR}/eglibc-${PV}/localedef"
 
meta/recipes-core/eglibc/eglibc_2.18.bb +3 -3
index ce416f7..2e1d380 100644
@@ -2,7 +2,7 @@ require eglibc.inc
 
 DEPENDS += "gperf-native kconfig-frontends-native"
 
-SRC_URI = "http://sakrah.dontexist.org/files/eglibc-${PV}-svnr23424.tar.bz2 \
+SRC_URI = "http://sakrah.dontexist.org/files/eglibc-${PV}-svnr23532.tar.bz2 \
            file://eglibc-svn-arm-lowlevellock-include-tls.patch \
            file://IO-acquire-lock-fix.patch \
            file://mips-rld-map-check.patch \
@@ -27,8 +27,8 @@ SRC_URI = "http://sakrah.dontexist.org/files/eglibc-${PV}-svnr23424.tar.bz2 \
            file://0001-eglibc-run-libm-err-tab.pl-with-specific-dirs-in-S.patch \
            file://fix-tibetian-locales.patch \
           "
-SRC_URI[md5sum] = "e7bb555f34e782d428de3482d203df8d"
-SRC_URI[sha256sum] = "3824e699a91a34aebbe80bae9993b569616fad2056e4f6430cd455d604fb1d9c"
+SRC_URI[md5sum] = "8c83078851c44089a019c626d51c51bb"
+SRC_URI[sha256sum] = "ecd3167d7d417c05b10ea7ab8e3acbc05f4bc2b389b6fae9c186bc0fd34c3ff1"
 
 LIC_FILES_CHKSUM = "file://LICENSES;md5=e9a558e243b36d3209f380deb394b213 \
       file://COPYING;md5=393a5ca445f6965873eca0259a17f833 \
Signature · 1 line
1.7.9.5