Undocumented IPv6 options
Subsystems (2)
Hello netdev,
Andrew McDonald kindly fixed the description of IPV6_ROUTER_ALERT in the ipv7.7 man page. As long as we're on the topic, I'll point out that the following IPV6 options (and possibly others) are still not documented on that page:
IPV6_CHECKSUMIPV6_JOIN_ANYCASTIPV6_LEAVE_ANYCASTIPV6_V6ONLYIPV6_RECVPKTINFOIPV6_2292PKTINFO
Can anyone help with documenting any of these please?
Cheers,
Michael
Signature · 6 lines
Michael Kerrisk maintainer of Linux man pages Sections 2, 3, 4, 5, and 7 Want to help with man page maintenance? Grab the latest tarball at http://www.kernel.org/pub/linux/docs/manpages/ read the HOWTOHELP file and grep the source files for 'FIXME'.
Quoted 7 lines · Michael Kerrisk
Hello netdev,
Andrew McDonald kindly fixed the description of
IPV6_ROUTER_ALERTin the ipv7.7 man page. As long as we're on the topic, I'll point out that the following IPV6 options (and possibly others) are still not documented on that page:
Quoted 8 lines
IPV6_CHECKSUMIPV6_JOIN_ANYCASTIPV6_LEAVE_ANYCASTIPV6_V6ONLYIPV6_RECVPKTINFOIPV6_2292PKTINFOCan anyone help with documenting any of these please?
RFC 2553 was obsoleted by RFC 3493, and it added IPV6_V6ONLY into Basic API.
RFC 2292 (IPV6 Advanced API) defines IPV6_CHECKSUM, and IPV6_PKTINFO (latter of which is known above as IPV6_2292PKTINFO)
RFC 3542 obsoletes RFC 2292, and defines IPV6_RECVPKTINFO, and modifies IPV6_PKTINFO.
The IPV6_JOIN_ANYCAST and IPV6_LEAVE_ANYCAST are not defined in any RFC.
Undocumented are also IPV6_JOIN_GROUP and IPV6_LEAVE_GROUP (RFC 2553 / 3493)
It really looks like time for major overhaul of that (and related) man-pages is needed...
Quoted 6 lines
Cheers,
Michael
Signature · 2 lines
Michael Kerrisk maintainer of Linux man pages Sections 2, 3, 4, 5, and 7
/Matti Aarnio
Quoted 2 lines · Matti Aarnio
Undocumented are also
IPV6_JOIN_GROUPandIPV6_LEAVE_GROUP(RFC 2553 / 3493)
The IPv6 man page was never complete when I wrote it long ago.
This
BUGS
...
This man page is not complete.
is still true.
Quoted 2 lines
It really looks like time for major overhaul of that (and related) man-pages is needed...
IPv6 just needs finishing.
One option actually since the RFCs document IPv6 basic and extended API very well would be to somehow pull them in similar to the POSIX manpages and let them speak for themselves.
I don't know if that is possible with the RFC copyrights though (?)
-Andi
Quoted 2 lines
It really looks like time for major overhaul of that (and related) man-pages is needed...
Yes. Andi Kleen did a good job of putting some pages together in the 2.2 timeframe, but no-one else carried on the work since then, and there is much that sould be updated in the *.7 networking pages.
Cheers,
Michael