Skip to contentSkip to conversation

New: uri.7: DESCRIPTION: Usage: ldap: Reference to obsolete IETF RFC 2255

Bug 215736 [email protected] 1 participant 3 messages Mar 24, 2022 Man-pages: manual pages for Linux -- Sections 2, 3, 4, 5, and 7

lore
Share & tools
lore
#0 lore raw

https://bugzilla.kernel.org/show_bug.cgi?id=215736

            Bug ID: 215736
           Summary: uri.7: DESCRIPTION: Usage: ldap: Reference to obsolete
                    IETF RFC 2255
           Product: Documentation
           Version: unspecified
          Hardware: All
                OS: Linux
            Status: NEW
          Severity: normal
          Priority: P1
         Component: man-pages
          Assignee: [email protected]
          Reporter: [email protected]
        Regression: No

uri(7)::DESCRIPTION::Usage::ldap reads as:

```
       ldap - Lightweight Directory Access Protocol

       ldap://hostport
       ldap://hostport/
       ldap://hostport/dn
       ldap://hostport/dn?attributes
       ldap://hostport/dn?attributes?scope
       ldap://hostport/dn?attributes?scope?filter
       ldap://hostport/dn?attributes?scope?filter?extensions

       This scheme supports queries to the Lightweight Directory
       Access  Protocol (LDAP), a protocol for querying a set of
       servers for hierarchically organized information (such as
       people   and   computing   resources).    See    RFC 2255
       <http://www.ietf.org/rfc/rfc2255.txt>   for more informa-
       tion on the LDAP URL scheme.  The components of this  URL
       are:

       [...]
```

It refers to an obsolete RFC[1]. We should update the info there.

[1]: <https://www.rfc-editor.org/rfc/rfc2255>

Signature · 4 lines
You may reply to this email to add a comment.

You are receiving this mail because:
You are watching the assignee of the bug.
#1 lore raw

[Bug 215736] uri.7: DESCRIPTION: Usage: ldap: Reference to obsolete IETF RFCs 2251, 2253, 2254, and 2255

https://bugzilla.kernel.org/show_bug.cgi?id=215736

Alejandro Colomar (man-pages) ([email protected]) changed:

What |Removed |Added
----------------------------------------------------------------------------

            Summary|uri.7: DESCRIPTION: Usage:  |uri.7: DESCRIPTION: Usage:
                   |ldap: Reference to obsolete |ldap: Reference to obsolete
                   |IETF RFC 2255               |IETF RFCs 2251, 2253, 2254,
                   |                            |and 2255

--- Comment #1 from Alejandro Colomar (man-pages) ([email protected]) --- More references to obsolete RFCs[2][3][4] in the same ldap entry:

```
       dn          the LDAP Distinguished Name, which identifies
                   the  base  object  of  the  LDAP  search (see
                   RFC 2253             <http://www.ietf.org/rfc
                   /rfc2253.txt>  section 3).

       attributes  a  comma-separated  list  of attributes to be
                   returned; see  RFC 2251  section  4.1.5.   If
                   omitted, all attributes should be returned.

       scope       specifies  the scope of the search, which can
                   be one of "base" (for a base object  search),
                   "one" (for a one-level search), or "sub" (for
                   a  subtree  search).   If  scope  is omitted,
                   "base" is assumed.

       filter      specifies the search filter  (subset  of  en-
                   tries  to  return).   If omitted, all entries
                   should    be    returned.     See    RFC 2254
                   <http://www.ietf.org/rfc/rfc2254.txt>    sec-
                   tion 4.
```

[2]: <https://www.rfc-editor.org/rfc/rfc2253>
[3]: <https://www.rfc-editor.org/rfc/rfc2251>
[4]: <https://www.rfc-editor.org/rfc/rfc2254>

Signature · 4 lines
You may reply to this email to add a comment.

You are receiving this mail because:
You are watching the assignee of the bug.
#2 lore raw

[Bug 215736] uri.7: DESCRIPTION: Usage: ldap: Reference to obsolete IETF RFCs 2251, 2253, 2254, and 2255

In reply to [email protected]