Will we have UPnP support for Linux?
http://www.e-insite.net/ednmag/index.asp?layout=article&articleId=CA154802
http://www.microsoft.com/windowsxp/expertzone/columns/bowman/december24.asp
http://www.upnp.org/
http://www.upnp.org/newsletters/newsletter_09_2002/
http://www.upnp.org/newsletters/newsletter_09_2002/committee.asp
http://hometoys.com/htinews/aug01/articles/microsoft/upnp.htm
UPnP Member companies:
http://www.upnp.org/membership/members.asp
Firmware supporting UPnP:
On Thu, 2002-10-31 at 19:47, Miles Lane wrote:
[UPnP URLs snipped]
Is this a kernel feature? AFAIK UPnP is just another application protocol on top of UDP, so it can be done in userspace. And didn't Intel release a UPnP stack on SourceForge? Whoa, I see 7 UPnP projects on SF; at least one of them is probably real.
Signature · 1 line
Wes Felter - [email protected] - http://felter.org/wesley/
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
Quoted 8 lines · Wes Felter
On Thu, 2002-10-31 at 19:47, Miles Lane wrote:
[UPnP URLs snipped]
Is this a kernel feature? AFAIK UPnP is just another application protocol on top of UDP, so it can be done in userspace. And didn't Intel release a UPnP stack on SourceForge? Whoa, I see 7 UPnP projects on SF; at least one of them is probably real.
Probably you want to go with the IETF approach - Service Location Protocol (RFC2608, RFC2609, RFC2610, RFC2614 and some others). There is a reasonable open source implementation (OpenSLP), and no dodgy vendor association.
Brad
- --
http://linux.conf.au. 22-25Jan2003. Perth, Aust. I'm registered. Are you? -----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.6 (GNU/Linux)
Comment: For info see http://www.gnupg.org
iD8DBQE9wwlMW6pHgIdAuOMRAvLKAJ9iUw3q7ISYSok2ULwnH+UJeHNCJgCfV37h 0X20BM031CdfL696wzioMfA=
=coAW
-----END PGP SIGNATURE-----